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Introduction

1  Introduction
The purpose of this quick start guide is to familiarise users with the KeilTM Microcontroller 
Development Kit (MDK-ARM) for the Holtek HT32 series of microcontrollers. The guide also 
includes information on the development kit installation and configuration. 

About the Quick Start Guide
The guide includes information on how to setup the KeilTM MDK-ARM as well as a guide for 
installing the HT32 support package for KeilTM. Necessary information is also provided about 
using the Keil µVision4 IDE (Integrated Development Environment) to compile and run software 
projects. A chapter is also dedicated on how to use the CodeSourcery GNU Toolchain with KeilTM 
μVision.
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Figure  1.  Software Development Flow 
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About the Keil MDK-ARM
The KeilTM MDK-ARM is a software development environment for ARM-based microcontrollers. 
The environment includes functions such as source code editor, complier, assembler, linker, project 
management, flash programmer and debugger. All of these functions are integrated into µVision4 
IDE which helps to create and debug C/C++/Assembler source files. The MDK-ARM provides the 
following key features for embedded applications.

▀  Supports Cortex-M series, Cortex-R4, ARM7 and ARM9 devices

▀  µVision IDE 
●  Device database for all supported devices
●  Editor, project management and compilation
●  Debugger environment including trace and analysis tools
●  Simulation environment

▀  RealView Compilation Tool (RVCT)
●  ARM C/C++ Compiler (armcc)
●  ARM Macro Assembler (armasm)
●  ARM Linker (armlink)
●  ARM Utilities (Librarian and FromELF)

▀  Mircolib-optimized run-time library

▀  KeilTM RTX Real-Time Operating System (RTOS)

▀  Flash Loader for Flash memory programming

▀  Example code for various boards and devices

NOTE: The above figure was extracted from the Keil website: http://www.keil.com

Figure  2.  KeilTM MDK-ARM Software Development Environment
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2  System Requirements
To get going with this quick start guide, several components are required as listed below:

▀  A target board with a HT32 series MCU

▀  A hardware debug adapter such as ULINK2 or Holtek’s e-Link32

▀  A host computer running Microsoft® Windows® XP, Vista, or Windows® 7
●  A recommended 1 GB RAM and 500 MB of available hard-disk space
●  XGA (1024x768) colour monitor or higher resolution display 
●  Mouse or other pointing device
●  A CD-ROM drive (optional)

▀  KeilTM MDK-ARM V3.04 or above

Target Board

Host PC

USB Interface

Debug Adapter

JTAG or SWD

IDE

Figure  3.  System Architecture and Requirements
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3  Software Installation

Keil MDK-ARM Installation 
The KeilTM MDK-ARM evaluation software can be downloaded from http://www.keil.com or from 
a CD-ROM provided by Holtek. The latest version of the MDK-ARM is regularly available at 
http://www.keil.com/update. Note that the evaluation version has a limitation on its 32 KB of image 
size. For more information about the setup process, please refer to the “Read Me First” document 
from the Keil’s website at: http://www.keil.com/product/brochures/readmefirst.pdf.

Installing the Keil HT32 Support Package 
(For MDK-ARM v4.20 or Below)

After the KeilTM MDK-ARM has been installed, the HT32 Support Package for KeilTM also has to 
be installed. This support package installs the device database, flash programming algorithms and 
all other files required for HT32 series MCU program development.

The following steps show how to install the support package into the KeilTM MDK-ARM.
Step 1: Obtain the latest version of the Support Package from the Holtek website or from the CD-

ROM provided by Holtek. The filename is “HT32_Keil_Package_Vnnn.exe” where “nnn” 
represents the version number.

Step 2: Execute the support package installation program by double-clicking on “HT32_Keil_
Package_Vnnn.exe”. Press the “Next” button to continue when the screen below appears.

Figure  4.  Support Package Installation

http://www.keil.com
http://www.keil.com/update
http://www.keil.com/product/brochures/readmefirst.pdf
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Step 3: The support package will detect the last installed path of the Keil MDK-ARM 
automatically. If the path found is not correct, press the “Browse” button to manually 
specify the required installed path for the MDK-ARM. Press the “Next” button to 
continue.

Figure  5.  Support Package Installation – Destination

Step 4: After the target path is confirmed, the ready-to-install page will be shown. Press the 
“Install” button to start the installation.

Figure  6.  Support Package Installation – Start Install
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Step 5: After the installation has completed, a completion page will appear. Choose whether or not 
to view the release note. Press the “Finish” button to exit the installation program.

Figure  7.  Support Package Installation – Completion
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4  Installing the USB Debug Adapter
The e-Link32 drivers can be obtained from the Holtek website or from the CD-ROM provided by 
Holtek. Below are the configuration steps for the e-Link32 USB drivers. 

Step 1: Connect the e-Link32 to the host PC via the USB port.

Step 2: The system will detect a new USB device and will start the driver installation procedure.

Step 3: Specify the driver path manually according to the USB debug adapter.

“C:\Program Files\Holtek HT32 Series\e-Link32 USB Driver\” – for e-Link32

The ULINK2 uses standard Human Interface Device (HID) drivers that are directly supported by 
Windows 2000/XP/Vista/7 operation systems. Therefore, no additional drivers are required.
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5  Connecting to the Target Board
The target board can be powered by the USB port or by an external 5V DC adaptor by changing the 
on-board jumpers. Refer to the corresponding target board documents for details. 

The USB debug adapter, ULINK2 or e-Link32, that is connected to the SWD or JTAG interface of 
the target board via the ARM 20-pin or 10-pin 2.54mm pitch connector, is used to help download 
and debug the embedded software on the target hardware.

The following figure shows the connection of host PC, USB debug adapter and target board.

Figure  8.  PC, USB Debug Adapter and Target Board Connection
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6  Keil MDK-ARM Quick Start
The KeilTM MDK-ARM provides a complete “KeilTM μVision” development tool for project 
creation. The tool can edit both C and assembly code, set up the development tools, view the 
assembler code, connect and perform tests. Visit the Keil website http://www.keil.com for more 
information.

Create and Save New Project
To create a new project, follow the steps below:

1. Make sure that the Keil Holtek HT32 Support Package has been installed.
2.  Double click on the “Keil μVision” shortcut or click “Start → All Programs →  

Keil μVision” to run the Keil μVision.
3. Choose ”Project → New μVision Project…” to create a new Keil project in the menu.

Figure  9.  Create New Project

http://www.keil.com/
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4. A “Create New Project” dialog will pop up. Specify the name and path of the project and press 
the “Save” button. The related information and files can then be found in the “Project” window.

Figure  10.  Create New Project Dialog

5. A “CPU Data Base File” dialog will pop up. Choose “Holtek HT32 Device Database” from the 
drop-down list.

Figure  11.  CPU Database Dialog
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6. Select the device name. Here, the “HT32F1253” device is used as an example.

Figure  12.  Select Project Device

Click “OK” button to complete the device selection. Decide whether to use the included startup 
code.

Figure  13.  Startup Code Inquiry Window
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Project Options Setup
The following section describes how to setup the project options including Device, USB debug 
adapter and Flash Loader.

Open Project Options Setup Page
1. There are two methods to enter the “Options for Target…” pages:

a. Right-click on the target name in the “Project” window to display the Context Menu and 
choose “Options for Target…” to open the option dialog.

b. Click the toolbar button “Options for Target”.

Figure  14.  Target Menu Options
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Device Selection
1. Open the “Options for Target…” dialog.
2. In the “Device” tab, choose “Holtek HT32 Device Database” from the “Database” drop-down 

list.
3. Select the device name. For example, “HT32F1253”.

Figure  15.  Select Project Device
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Configure the USB Debug Adapter
The following shows the method of configuring the Keil μVision USB debug adapter. This example 
will take the ULINK2 as an example.

1. Connect the ULINK2 to the PC.
2. Open the “Options for Target…” dialog.
3. Click the “Debug” tab. The left side is for the simulator options while the right side is for the 

USB debug adapter options. Select “ULINK Cortex Debugger”.
4. Check “Load Application at Startup” and the application will then be pre-loaded into the “Debug 

mode”. If “Run to main()” is checked, the application will first be run to “main()” in the “Debug 
mode”.

Figure  16.  Target Debug Tab Page Options
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5. Click the “Settings” button to open the “Cortex-M Target Driver Setup” dialog.
a. Select the debug adapter “Serial No” from the drop-down menu.
b. Select “Port” as “SW” or “JTAG”. Note that some HT32 devices only support the “SW” 

interface.
c. If “SWJ” is enabled, the ULINK2 will generate the required sequences on the Serial Wire 

/ JTAG debug port (SWJ-DP) to switch between the JTAG and SWD interface. Therefore, 
enable “SWJ” on devices with SWJ-DP and disable “SWJ” on devices that have only a SW-
DP or JTAG-DP interface.

d. For details of any other settings, refer to the documents on the Keil website. 
http://www.keil.com/support/man/docs/ulink2/ulink2_ctx_debugdrivercfg.htm

Figure  17.  ARM Target Driver Setup Page
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Flash Loader Setup
The Flash loader is used to download the program into the device flash memory. It is executed in 
the SRAM and receives data from the host PC, through the USB debug adapter. It then loads the 
data into the flash memory.

1. Open the “Options for Target” dialog.
2. Select the “Utilities” tab and open the Settings dialog. In this example, select the ULINK Cortex 

Debugger. Tick “Update Target before Debugging” to download the image into Flash memory 
automatically.

Figure  18.  Utilities Tab Menu
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3. Setup both the Programming Algorithm start position and memory size in this dialog. The start 
position is 0x20000000 and the size is 0x0800 (2 kB) for HT32 Series MCUs. 

4. Click the “Add” button and choose “HT32 Series Flash” from the list box. To program the 
Option Bytes, choose the “HT32 Series Flash Options” in the same way.

Figure  19.  Target Driver Flash Download Tab

Figure  20.  Flash Programming Algorithm Select
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5. Once all the setups have finished, the HT32 Series Flash will be listed in the Programming 
Algorithm dialog and can therefore be programmed using the Keil μVision.

Figure  21.  Flash Programming Algorithm
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Adding Source Files to the Project
Source code can be added into the project using the following procedure:

1. Click the “New” icon in the toolbar or click “File → New…” to create a new file.

Figure  22.  New File Creation
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2. Edit the code shown below in the editor window. Click “File → Save” and save as “main.c” 
	 int main(void)
	 {
		  int i = 0;
		  int j = 0x20001000;
		  while(1)
		  {
			   *(int *)j = i;
			   i++;
		  }
	 }

Figure  23.  Save File



Rev. 1.10	 25 of 47 August 25, 2011

32-bit ARM Cortex™-M3 MCU
HT32 Series

K
eil M

D
K

-A
R

M
 Q

uick Start

3. Right click on the “Source Group” and select “Add Files to Group…” to add the “main.c” file 
into the project.

Figure  24.  Add File to Group

Figure  25.  Add File to Group – Specify File Name and Path



Rev. 1.10	 26 of 47 August 25, 2011

32-bit ARM Cortex™-M3 MCU
HT32 Series

K
eil M

D
K

-A
R

M
 Q

uick Start

4. Select the “Components, Environment, and Books” function to rename, add files, re-order and so 
on for the project source files. 

Figure  26.  Components, Environment and Books Function

Figure  27.  Modify Project Components
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Figure  28.  Project Component List
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7  Compiling the Project
Use the following procedure to compile the project:

1. Choose “Project → Rebuild all target files” to recompile all the files in the project.

Figure  29.  Build All target Files

2. Check the “Build Output” message to confirm if the project has been successfully built and 
linked.

Figure  30.  Compiler Messages
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8  Download and Debug
The following section shows how to download the application and use the debug features such as 
free running, break, single step and breakpoint.

Enter/Exit Debug Mode
1. Click “Debug → Start/Stop Debug Session (Ctrl + F5)” or the “Debug” icon to enter the debug 

mode. The image will be downloaded into Flash memory automatically when the “Update Target 
before Debugging” option is enabled.

Figure  31.  Start Debugging Session
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2. After the debugging is finished, click “Debug → Start/Stop Debug Session (Ctrl + F5)” or the 
“Debug” icon again to exit the debug mode.

3. The debug window as shown below will appear which will display information regarding 
“Registers”, “Disassembly”, “Source Code Window”, “Memory Window”, “Command” and so 
on.

Figure  32.  Debugging Session
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Free Running, Break, and Single Step Operation
The debugger provides Free Running, Break and Single Step functions to assist with application 
debug.

1. Click the “Run” icon to allow the program to free run. 

Figure  33.  Run Icon

2. Click the “Stop” icon to stop free running.

Figure  34.  Stop Icon

3. Click the “Step” icon or “F11” to single step the program. Use this feature to debug the program 
step by step.

Figure  35.  Step Icon 
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Breakpoints
Breakpoints can be setup to halt the program at user specified program locations to allow program 
status examination at these user defined locations. The following procedure shows how this is 
implemented:

1. Before the program starts running double click on the desired breakpoint program line to set 
the breakpoint. A red point mark will then be displayed next to the breakpoint line. Multiple 
breakpoints can be setup using this method. 

Figure  36.  Breakpoint Setup
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2. Click the “Run” icon to start the program. The program will run normally until it encounters the 
first breakpoint where it will halt execution. A yellow arrow will indicate the present program 
execution location.

Figure  37.  Breakpoint Program Stop
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Memory Window
A function is included to examine user selected memory contents. 

1. Click “View → Memory Windows → Memory 1” to open the memory window.

Figure  38.  Open Memory Window

2. Type “0x20001000” into the “Address” input box to view the memory contents.

Figure  39.  Address 0x20001000 Memory Contents Window
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3. Click the “Step” icon or “F11” to single step the program. Use this to examine consecutive 
memory contents.

Figure  40.  Memory Content Examination
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9  Mass Erase 
Mass erase is an operation that erases the whole flash memory including the main flash memory 
and the Option Bytes. It can be used to clear all the data in the flash memory or to disable the 
security settings.

1. In the μVision window, Click “Flash → Erase”

Figure  41.  Mass Erase Function

2. After a mass erase operation has completed, a “Build Output” message window will display a 
message to notify that the flash memory has been successfully erased.

Figure  42.  Build Output Message Window
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10  Option Bytes Programming
Option Byte Programming provides protection for flash page erase/programming and for enhanced 
device security.

1. Copy “ht32f125x_op.s” to the project folder. The original “ht32f125x_op.s” file is located in the 
Keil installation folder: “{KEIL_PATH}\ARM\Startup\Holtek”.

Figure  43.  Option Bytes Setup File
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2. Right click on the item in the Project window, then select “Add Files to Group” to add the Option 
Byte setup file.

Figure  44.  Add Option Bytes File

Figure  45.  Add Files to Group Dialog
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3. Select the Option Byte file and change the values using the “Configuration Wizard” according to 
actual requirements.

Figure  46.  Option Bytes Configuration Wizard

4. Rebuild all the files once the Option Bytes setup is complete. These Option Bytes will be 
programmed into the HT32 series MCU automatically when the download procedure starts. 
NOTE: To program the Option Bytes, confirm that the “HT32 Series Flash Options” are 
listed in the Programming Algorithm dialog. Refer to the Flash Loader Setup section for more 
information.



Rev. 1.10	 40 of 47 August 25, 2011

32-bit ARM Cortex™-M3 MCU
HT32 Series

U
sing the C

odeSourcery G
N

U
 Toolchain w

ith K
eil μVision

11  Using the CodeSourcery GNU Toolchain with Keil μVision

CodeSourcery have developed a GNU Toolchain for ARM processors and provide regular, 
validated releases of the GNU Toolchain. The Sourcery G++ Lite Edition supports ARM, Thumb, 
and Thumb-2 compilation for all architectures, including the ARMv7.

This section describes how to configure the KeilTM µVision and install the Sourcery G++ Lite 
Edition to use the CodeSourcery GNU ARM tool chain. 

Installing the Sourcery G++ Lite Edition
The Sourcery G++ Lite Edition contains free and command-line only versions of the core 
development tools. The latest version can be downloaded from the following website:
http://www.codesourcery.com/gnu_toolchains/arm/download.html

For general cases, the EABI version for the non-OS applications of Cortex-M3 can be used. For 
more information about the setup process, refer to the “Getting Started Guide” document from the 
CodeSourcery website.
(http://www.codesourcery.com/sgpp/lite/arm/portal/doc9876/getting-started.pdf).

Configuring Keil μVision for Sourcery G++
The following contents assume that a project has been created. For more information regarding 
creating a project, refer to Chapter 6 Keil MDK-ARM Quick Start. Note that the following steps 
will reset all the options to their default value. It is important to first backup the project.

http://www.codesourcery.com/gnu_toolchains/arm/download.html
http://www.codesourcery.com/sgpp/lite/arm/portal/doc9876/getting-started.pdf
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1. Open or create a project and right-click on the target name in the “Project” window to display 
the Context Menu and choose “Manage Components…” to open the “Components, Environment 
and Books” dialog.

Figure  47.  Open Components, Environment and Books Dialog
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2. Click the “Folders/Extensions” tab, change the setting as shown in Figure  48. If “Use GNU 
Compiler” is checked, a warning message will be displayed to notify that all the options in the 
project will be reset to their default values. Reconfirm that the project has already been backed 
up and press “Yes” to continue. Select or modify the installed paths of µVision or Sourcery G++ 
if required.

Figure  48.  Folders/Extensions Setup Change

Figure  49.  “Use GNU Compiler” Warning Message
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3. Refer to Section Project Options Setup to setup the project options such as USB 
adapter or Flash loader. Additionally, modify also the Linker settings as shown 
in the accompanying diagram. The linker script file can be found in the example 
code of  the HT32 Keil  quick start  guide,  obtainable from the Holtek website. 
Path: \\Quick_Start_Example_Keil\SourceryG++Lite\

Figure  50.  Linker Options
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4. In the “CC” tab, tick “Compile Thumb Code” for the Cortex-M3.

Figure  51.  C Compiler Options

5 .  The  s t a r t up  f i l e  shou ld  be  changed  fo r  t he  GNU Too lcha in .  Fo r  example , 
r e m o v e  t h e  o r i g i n a l  “ s t a r t u p _ h t 3 2 f 1 2 5 x . s ”  a n d  a d d  t h e  n e w  o n e  t o  t h e 
project .  The s tar tup f i le  for  Sourcery G++ can be found in the example code 
o f  t h e  H T 3 2  K e i l  q u i c k  s t a r t  g u i d e ,  o b t a i n a b l e  f r o m  t h e  H o l t e k  w e b s i t e . 
Path: \\Quick_Start_Example_Keil\SourceryG++Lite\
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6. Choose “Project → Rebuild all target files” to recompile all the files in the project. Check the 
“Build Output” message to confirm if the project has been successfully built and linked.

Figure  52.  GNU Toolchain Compiler Messages
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12  Conclusion
All the necessary items for developing embedded software such as Keil MDK-ARM, USB debug 
adapter, software project, debugging environment have been provided in this document. A brief 
introduction to the creation, management, building and debugging of software has also been 
provided to help get started with software development using the Keil MDK-ARM for Holtek ‘s 
HT32 series microcontrollers.

To help users start creating their own HT32 series applications, Holtek provides a related firmware 
library, example code, documents and other services to reduce the user development cycle time. 
Additional further technical support such as application notes etc. can be obtained from the Holtek 
website. 
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